Results 1 to 5 of 5

Thread: early 911 alternator test

  1. #1
    PNW 73S
    Guest

    early 911 alternator test

    Greetings all,

    I suspect the Marchal alternator on my '73 911 to be faulty, but I'm not familiar enough with the early 911's charging system to know for sure. On many vehicles, simply disconnecting the negative battery cable with the engine running can indicate a faulty alternator....if the engine dies, the alternator isn't charging.

    I tried this on my 911 and the engine does indeed die. Can someone with experience in this area if this is conclusive evidence that the alternator is the problem?

    To give a little background on the problem, I washed the car over the weekend and when I went to start it the next day, the electrical system was completely dead. So I jumped started the vehicle and it ran fine for about 5 minutes before it died...the electrical system completely drained again. This occured 3-4 times. Each time the car is jumpstarted, the alternator light comes on. Bright at first, then gradually dimmer...and dimmer...and dimmer, until it goes out and then the engine dies and everything goes dead.

    Any thoughts?

    Thanx,
    Tony

  2. #2
    pwd72s
    Guest
    THis link should help : forums.pelicanparts.com/s...adid=72965

  3. #3
    911SRegistry
    Guest
    With all due respects to the Pelican thread, not entirely correct.

    A fully charged battery should be in the neighborhood of 13.2 volts. If it's lower than this, make sure its fully charged before you test the vehicle's electrical system. A load test can confirm the battery is okay.

    With accessories ON and car running at around 2000 rpm or so, the charging system should be putting out about 14.5 volts. If not, the charging system is not working correctly (bad alternator, regulator, component connections, ground).

    The alternator supplies most of the electricity while the car is running. The battery is there primarily for starting (cranking the engine) and for low idle speeds.

    Do not disconnect any battery cable while the engine is running. If your alternator was functioning okay before this, it won't after disconnecting it (unless you feel lucky).

    The alternator light indicates the battery is not charging. It should light with the ignition ON (engine OFF) to indicate it's functioning, but should be OFF while the engine is running.

    Washing your car and electrical system dieing may be coicidental. Not sure what you washed. I'd suggest charging the battery, perform the above checks, then drive it down to a good automotive electrical shop for a thorough diagnosis. You should be able to pay them to just diagnosis; not repair if you want to DIY.

    Hope this helps,
    Sherwood Lee

  4. #4
    PNW 73S
    Guest
    Hello again,

    I thought you might like to know that the SEV Marchal voltage regulator was faulty and responsible for the problems I posted earlier. After swapping it out for a Transpo #ID4010 unit, the car fired right up and is running great. I'd like to find another Marchal regulator for authenticity purposes, does anyone have any suggestions on where I might be able to locate one???

    I can only assume that some water managed to seep into the Marchal case and shorted the unit out, but maybe it's just a coincidence.

    For those of you in the Seattle area, I highly recommend Romaine Electric if you ever need assistance with your charging system. They were very helpful.

    Thanks again for everyone's help, and have an excellent 4th!

    Very best,
    Tony Curless

  5. #5
    pwd72s
    Guest
    Always great to hear of a good ending...

Similar Threads

  1. FS: Early 911 Fan & Alternator Assembly
    By rennmark71 in forum For Sale: 911 Parts
    Replies: 1
    Last Post: 06-28-2011, 01:29 PM
  2. Early 911 Test What is it? I know.
    By BBausser in forum General Info
    Replies: 2
    Last Post: 09-26-2010, 03:58 PM
  3. Early Al Fan Housing, Fan & Alternator
    By Shaun 69 E in forum For Sale: 911 Parts
    Replies: 0
    Last Post: 01-09-2010, 02:00 PM
  4. Early 911 alternator housing 64-65?
    By Eric911S in forum For Sale: 911 Parts
    Replies: 0
    Last Post: 07-20-2005, 10:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Message Board Disclaimer
This is a public forum. Messages posted here can be viewed by the public. The Early 911S Registry is not responsible for messages posted in its online forums, and any message will express the views of the author and not the Early 911S Registry. Use of online forums shall constitute the agreement of the user not to post anything of religious or political content, false and defamatory, inaccurate, abusive, vulgar, hateful, harassing, obscene, profane, sexually oriented, threatening, invasive of a person's privacy, or otherwise to violate the law and the further agreement of the user to be solely responsible for and hold the Early 911S Registry harmless in the event of any claim based on their message. Any viewer who finds a message objectionable should contact us immediately by email. The Early 911S Registry has the ability to remove objectionable messages and we will make every effort to do so, within a reasonable time frame, if we determine that removal is necessary.