Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25

Thread: Help needed diagnosing Weber 40 IDA 3C problem

  1. #21
    Thanks for the suggestions addressing my request for help, guys.

    As I said before, it’s not clear how soon I’ll get to investigate the problem further (due to travel, birthday and family commitments). But when I do, I’ll report back …
    Bob Schaefer

    67 911S (Canary / Lemon yellow sunroof coupe w/100l tank on COA & Kardex 1 of 1 produced??)



    70 914/6 (2.7l RS spec engine, but searching for 6404915 original)

  2. #22
    Quote Originally Posted by 1QuickS View Post
    I remain suspicious of the Webers having ingested a bit of debris on either one or more idle air correction jets or on an emulsion tube. Partial throttle would demand fuel delivery through these components but WOT is main circuit only. I have personally experienced these two scenarios, a bit of rust from air cleaner blocked an idle air correction jet and another time a bit of paper towel blocked a small section of one emulsion tube and both times I had WOT to redline but troubled partial throttle operation.

    ...
    You nailed it Paul! Thanks so much for your help.
    Attached Images Attached Images  
    Bob Schaefer

    67 911S (Canary / Lemon yellow sunroof coupe w/100l tank on COA & Kardex 1 of 1 produced??)



    70 914/6 (2.7l RS spec engine, but searching for 6404915 original)

  3. #23
    Congratulations! Not the air correction jet I was thinking about but it is at least an air correction jet.

    Easy fix!
    Paul Abbott
    Early S Member #18
    Weber service specialist
    www.PerformanceOriented.com
    info@PerformanceOriented.com
    530.520.5816

  4. #24
    Is that a tree limb caught in there? Thanks Bob for finishing the thread, not everyone does,,,,and chalk up one for Paul
    Early S Registry member #90
    R Gruppe member #138
    Fort Worth Tx.

  5. #25
    Quote Originally Posted by edmayo View Post
    Is that a tree limb caught in there? Thanks Bob for finishing the thread, not everyone does,,,,and chalk up one for Paul
    Oddly, it looked like a piece of aged / soiled clear silicon caulking that had been applied to a cover / gasket surface.
    Bob Schaefer

    67 911S (Canary / Lemon yellow sunroof coupe w/100l tank on COA & Kardex 1 of 1 produced??)



    70 914/6 (2.7l RS spec engine, but searching for 6404915 original)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Message Board Disclaimer and Terms of Use
This is a public forum. Messages posted here can be viewed by the public. The Early 911S Registry is not responsible for messages posted in its online forums, and any message will express the views of the author and not the Early 911S Registry. Use of online forums shall constitute the agreement of the user not to post anything of religious or political content, false and defamatory, inaccurate, abusive, vulgar, hateful, harassing, obscene, profane, sexually oriented, threatening, invasive of a person's privacy, or otherwise to violate the law and the further agreement of the user to be solely responsible for and hold the Early 911S Registry harmless in the event of any claim based on their message. Any viewer who finds a message objectionable should contact us immediately by email. The Early 911S Registry has the ability to remove objectionable messages and we will make every effort to do so, within a reasonable time frame, if we determine that removal is necessary.