Results 1 to 5 of 5

Thread: Mystery switch in a 74

  1. #1
    Senior Member Scott A's Avatar
    Join Date
    May 2014
    Location
    California
    Posts
    580

    Mystery switch in a 74

    I am fixing this car for a neighbor lady, her husband (with debilitating dementia) has had the car soon to be 50 yrs.
    it’s a 1974. Original 2.7 CIS engine, Original paint, near 100% stock, garage kept car in remarkable shape.
    Everything, lights, gauges, etc. on the car works fine. Starts easy. Runs well.

    It has this one modification:
    A switch near the parking brake.
    Wired into the 3 fuse panel in the engine. With another wire that seems to go into the fuel injection components.
    The switch doesn't "click", it just pushes down. And comes back up when you let go.

    I can't figure out what it is for??

    I haven't pushed it while the car is running.
    It doesn't seem to be an alarm or remote start.
    I turned the switch a little for the photo.

    Any guesses what people added to their CIS cars?

    Name:  2F9032E8-4D75-46F5-B643-FA89565A8897.jpg
Views: 160
Size:  80.7 KB

    Name:  047981F7-DDDC-4F81-AEE5-7F1822260133.jpg
Views: 161
Size:  138.9 KB

    Also, a bonus question, what year did they offer black Fuchs? Could it have been 1974?
    Last edited by Scott A; 11-21-2021 at 07:43 AM.
    6

  2. #2
    Senior Member
    Join Date
    Nov 2014
    Location
    New York
    Posts
    223
    Is it a fuel pump cut off?

  3. #3
    #2922
    Join Date
    Oct 2010
    Location
    Sweden
    Posts
    145
    my guess; for cold starting
    Light Yellow -74
    @lagteknik

  4. #4
    Senior Member HughH's Avatar
    Join Date
    Dec 2004
    Location
    Melbourne Australia
    Posts
    2,336
    That sounds possible. I have a similar one but on the dash while it is pushed down it squirts some fuel. So a couple of quick pushes when cold gives an almost instant start. But that is for a MFI car not a CIS one.
    Hugh Hodges
    73 911E
    Melbourne Australia

    Foundation Member #005
    Australian TYP901 Register Inc.

    Early S Registry #776

  5. #5
    Senior Member majordad's Avatar
    Join Date
    Dec 2012
    Location
    Cork , Ireland
    Posts
    428
    I fitted similar to my MFI 2.4S, it’s purpose to help cold starting by squirting fuel into the engine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Message Board Disclaimer and Terms of Use
This is a public forum. Messages posted here can be viewed by the public. The Early 911S Registry is not responsible for messages posted in its online forums, and any message will express the views of the author and not the Early 911S Registry. Use of online forums shall constitute the agreement of the user not to post anything of religious or political content, false and defamatory, inaccurate, abusive, vulgar, hateful, harassing, obscene, profane, sexually oriented, threatening, invasive of a person's privacy, or otherwise to violate the law and the further agreement of the user to be solely responsible for and hold the Early 911S Registry harmless in the event of any claim based on their message. Any viewer who finds a message objectionable should contact us immediately by email. The Early 911S Registry has the ability to remove objectionable messages and we will make every effort to do so, within a reasonable time frame, if we determine that removal is necessary.