Results 1 to 9 of 9

Thread: 3.0 Engine low power problem

  1. #1

    3.0 Engine low power problem

    Hi all, hope I can pick some brains!
    I have on the bench a 3.0SC motor, RSR mahle 95mm high comp pistons, SC heads, ported, compression ratio works out around 10.1-1, DC80 cams, high butterlfy MFI. Single plug, tuned length headers and a rear box with no internals.
    Engine makes 200 hp on a dyno with a big flat spot at 5000rpm, pulling my hair out with it, could it be an exhaust issue? Or inlet? Or just a bad missmatch?
    Initially thought low compression with a 90cc SC head but ratio is up. Pump has been re-done.
    I'm tempted to fit a set of carbs and standard SSI set up to see if I get any better results? !
    Cheers in advance.

  2. #2
    Moderator Chuck Miller's Avatar
    Join Date
    Oct 2002
    Location
    Reseda, CA.
    Posts
    12,009
    Hmmm... I'll let the pros weigh in... however if you're in my state of CA at 10.1 with single plug, you may be run'n into an octane issue... just say'n

    We'll see what the pros say...

    Good luck,
    cm
    Chuck Miller
    Creative Advisor/Message Board Moderator - Early 911S Registry #109
    R Gruppe #88

    TYP901 #62
    '73S cpe #1099 - Matched # 2.7/9.5 RS spec rebuild
    '67 Malibu 327 spt cpe - Period 350 Rebuild

    ’98 Chevy S-10 – Utility
    ’15 GTI – Commuter

  3. #3
    Member #226 R Gruppe Life Member #147
    Join Date
    Feb 2009
    Location
    Portland, Oregon
    Posts
    2,199
    Who did the pump, and to what spec? Gordon

  4. #4
    Senior Member NZVW's Avatar
    Join Date
    Feb 2017
    Location
    Auckland NZ
    Posts
    1,678
    Quote Originally Posted by gled49 View Post
    Who did the pump, and to what spec? Gordon
    2nd that

    Flat from 5k to ?? or just flat from 5000

    Mark

  5. #5
    And you've checked your total ignition advance ?
    Early S Registry member #90
    R Gruppe member #138
    Fort Worth Tx.

  6. #6
    Banned
    Join Date
    Nov 2004
    Location
    Scottsdale, AZ
    Posts
    9,752
    Please post the dyno sheet otherwise this whole exercise is a comedy routine.

    Thanks.

  7. #7
    Member
    Join Date
    Jan 2016
    Location
    Bad Münstereifel--Germany
    Posts
    51
    DC 80???? The Konfiguration is mayby not perfekt? Take vor this a S Cam.....

  8. #8
    Broken valve spring??
    Early S Registry member #90
    R Gruppe member #138
    Fort Worth Tx.

  9. #9
    Banned
    Join Date
    Nov 2004
    Location
    Scottsdale, AZ
    Posts
    9,752
    Still waiting for dyno sheet.


    I do hope the OP updates his post. Nothing more frustrating than someone seeking free advice then disappearing. When that happens one can only assume someone was stupid and embarrassment soon followed.
    Last edited by Frank Beck; 02-27-2018 at 03:21 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Message Board Disclaimer and Terms of Use
This is a public forum. Messages posted here can be viewed by the public. The Early 911S Registry is not responsible for messages posted in its online forums, and any message will express the views of the author and not the Early 911S Registry. Use of online forums shall constitute the agreement of the user not to post anything of religious or political content, false and defamatory, inaccurate, abusive, vulgar, hateful, harassing, obscene, profane, sexually oriented, threatening, invasive of a person's privacy, or otherwise to violate the law and the further agreement of the user to be solely responsible for and hold the Early 911S Registry harmless in the event of any claim based on their message. Any viewer who finds a message objectionable should contact us immediately by email. The Early 911S Registry has the ability to remove objectionable messages and we will make every effort to do so, within a reasonable time frame, if we determine that removal is necessary.